Running Nutanix Community Edition nested on VMware Workstation

It is now possible to install and run Nutanix Community Edition (Version 2015.06.06) nested on VMware Fusion and VMware Workstation. 

Joep Piscaer has detailed install guide for Fusion that also works for Workstation – http://www.virtuallifestyle.nl/2015/06/nextconf-running-nutanix-community-edition-nested-on-fusion/

UPDATE – This issue occurred with version ce-2015.06.06-beta. This issue no longer exist with version ce-2015.06.08-beta.

Only problem I ran into was that I was getting following error from the installer:

INFO: Nutanix Community Edition cannot be installed on this hardware. Reason:
INFO: A set of disks matched the minimum requirements was not found.

After some digging I found that both of the added SCSI drives were identified as spinning disks although they both were stored on SSD. To fix this issue:

  • Login as root. Password – “nutanix/4u”
  • Identify your “SSD” and “HDD” -> “fdisk -l”. In my setup “SSD” is “/dev/sda”
  • Run “cat /sys/block/sda/queue/rotational”. 0 means SSD and 1 means HDD.
  • Run “echo 0 > /sys/block/sda/queue/rotational” to change the value from 1 to 0.
  • Rerun the installer

Now the installer was happy with my setup and after few minutes I had Nutanix Community Edition up and running on VMware Workstation.

Advertisements

17 thoughts on “Running Nutanix Community Edition nested on VMware Workstation

  1. Pingback: Nutanix Community Edition Deployment Options | Invisible Infrastructure
  2. Hey Kalle, I did a couple of tweaks on the config files, but could not install it. In my setup, I am only using Virtual SSDs emulated from vmware workstation(not actual SSDs). Please advise on this.

  3. I have customized the hot(ssd) & cold(hdd) tier along with Iops in the config files to match my requirement for my virtualSSDs but no luck. Please advise.

  4. Pingback: Nutanix Community Edition on ESXi | rtfmp
  5. Pingback: [Nutanix] NPP Journey – All about Cloud Ecosystem based on VMware & Nutanix
  6. Pingback: Install Nutanix on ESXi Links | JNewmaster
  7. Looks like is not possible to modify /sys/block/sdxxx/queue/rotational any more… tried also editing with vi. Any ideas?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s